Afin d'utiliser la syntaxe propre aux ECMAScript modules (avec les mots clés "export" et "import") plutôt que la syntaxe par défaut de CommonJS (avec"module.exports" et "require"), il faut installer quelques plugins Babel :

npm i -D babel-jest @babel/core @babel/preset-env
npm i -D babel-plugin-transform-es2015-modules-commonjs


et ajouter un fichier de configuration Babel : ".babelrc" (attention au point devant le nom de fichier). Ce ficher de configuration doit contenir ce qui suit :

{ "env": { "test": { "plugins": ["transform-es2015-modules-commonjs"] } } }